Outlook 2010: invia a destinatario di posta non funziona

Mi è capitato più volte di incorrere in questo tipo di errore. La funzione ‘invia a destinatario di posta’ di outlook 2010, ad un certo punto non funziona più.
Cliccando sul nome di un file col tasto destro del  mouse, appare l’elenco di opzioni disponibili; tra queste l’utilissima ‘invia a destinatario di posta’ che consente di allegare il file evidenziato ad un messaggio di posta outlook. Il problema è che cliccandoci sopra, non accade nulla. Il file selezionato non viene inviato da nessuna parte, tantomeno allegato ad un nuovo messaggio di outlook.

Per risolvere il problema ho consultato diversi forum ma le soluzioni proposte spesso non portano a risultati.

Tra queste:
controllare che outlook sia il client di posta predefinito
fatto! Ma non ha risolto il problema

eseguire da prompt dei comandi il comando: FIXMAPI
fatto! Ma non mi ha risolto il problema

aggiornare office 2010 al service pack 1
fatto! in alcuni casi risolve, in altri il problema persiste

reinstallare completamente office
fatto! quasi sempre risolve il problema, ma mi sembra una soluzione drastica.


L’unica soluzione che fin’ora ha sempre funzionato e quella di ricreare il collegamento ‘send to’ nel menu’ contestuale di windows.
Per farlo basta creare sul desktop un nuovo collegamento di questo tipo:

“C:\Program Files\Microsoft Office\Office14\OUTLOOK.EXE” /c ipm.note /a

Per info sul significato degli switch consultare la pagina: Command-line switches for Microsoft Office Outlook 2007

Una volta fatto, salviamo il nuovo collegamento come: “destinatario Outlook

Successivamente copiamo il collegamento appena creato nella cartella SendTo:

per Window7/vista:
C:\Users\username\AppData\Roaming\Microsoft\Windows\SendTo

oppure per Windows Xp:
C:\Documents and Settings\username\SendTo

Testiamo il tutto, cliccando col tasto destro del mouse su un file che vogliamo allegare ad un messaggio di posta. Apparirà ‘invia a’ con la nuova voce appena creata “destinatario Outlook”